FmDose for Motioncor2 wrapper

I just tried out the new motioncor2 wrapper and realized that there is an error in the script.
The electron dose (FmDose) is set to the total dose by the wrapper. In fact it should be divided by the no. of frames, since the framedose is asked.
Maybe you can fix this in the next release, for now it only helps to change the dose during import of the movies to the framedose. All settings in the extra command string are overwritten in my case.


1 Like

Hi @tarek, thanks for reporting, this is on our list.

Just realized that this bug is still not fixed in the latest revision.
A function to override the dose rate set during import, as present for the other alignment routines, would do the trick.

Hello, I also encountered this issue. I am trying to use motioncor2 to get around a Patch Motion Memory Error with that was reported a couple days ago. I tried to override the total dose by entering the actual FmDose value in the Extra Command String box, but the total dose persisted when the job was queued.

Hi @DaveT, @tarek,

Sorry for the delay- this bug is fixed, and we have also added options to override these parameters. This has been released in the latest version of cryoSPARC, v2.15.0.


I’m doing preprocessing myself, so I also came across the FmDose issue and another one: gain flipping and rotating do not translate properly to motioncor2 command from micrograph import job.

Import job:
Flip gain ref in X? no (motioncor2: horizontal flip = X)
Flip gain ref in Y? yes (motioncor2: for vertical flip = Y)
Rotate gain ref? 2 (2*90°)

motioncor2 job:
Running MotionCor2 command: /programs/x86_64-linux/motioncor2/1.3.1/MotionCor2_v1.3.1-Cuda101 -InTiff /mnt/XXXXX/EPU_dataset/P1/J11/imported/FoilHole_1_fractions.tiff -OutMrc /mnt/XXXXX/EPU_dataset/P1/J15/motioncorrected/11195781973528247604_FoilHole_1_fractions_motioncor2_aligned.mrc -Gain /mnt/XXXXX/EPU_dataset/P1/J11/imported/gain.mrc -Patch 5.0 5.0 -Kv 300.0 -PixSize 0.34 -FmDose 1.53947368421 -Gpu 0 -GpuMemUsage 0.8 -LogFile /mnt/XXXXX/EPU_dataset/P1/J15/motioncor2_logs/0 -FlipGain 1 -RotGain 1

Motioncor2 uses -FlipGain 1 for horizontal flip = flip around X, and -RotGain 1 rotates only by 90°. This is not what I selected while importing the micrographs.

The new version 2.15 just came out, and resolved the FmDose issue, but this remained. Is there a way to fix this soon with the new patch system?